Back to overview
Degraded
We're currently experiencing issues
Oct 20 at 04:52pm AWST
Affected services
Member App
Business App
halth.com
Resolved
Oct 20 at 05:24pm AWST
We experienced a temporary outage due to a global service provider having issues, rest assured we’re back online and the team are keeping a close eye on the situation.
Throughout this period, platform security remained unaffected, and because HaltH securely stores cards on file, transactions were still able to take place — unlike traditional terminal outages.
Affected services
Created
Oct 20 at 04:52pm AWST
We are experiencing intermittent issues that appear to be related to a widespread internet outage.
Affected services